<sup id="sjju3"><noscript id="sjju3"></noscript></sup>
    <big id="sjju3"></big>

  • <blockquote id="sjju3"></blockquote>
    <blockquote id="sjju3"></blockquote>

      <td id="sjju3"></td>

      <big id="sjju3"></big>
        <code id="sjju3"><strong id="sjju3"><dl id="sjju3"></dl></strong></code>
      1. 易语言地下城与勇士辅助顺图类源码

         更新时间:2019年02月20日 10:18:46   作者:易语言源码教程   我要评论

        今天小编就为大家分享一篇关于易语言地下城与勇士辅助顺图类源码,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧

        DNF辅助顺图类源码

        仅供学习参考,禁止商业用途

        .版本 2
        .程序集 顺图
        .子程序 顺图结构
        .参数 方向ID, 整数型
        .局部变量 一级偏移, 整数型
        .局部变量 二级偏移, 整数型
        .局部变量 临时数据, 整数型
        .局部变量 坐标结构, 整数型
        .局部变量 x, 整数型
        .局部变量 y, 整数型
        .局部变量 xF, 整数型
        .局部变量 yF, 整数型
        .局部变量 cx, 整数型
        .局部变量 cy, 整数型
        一级偏移 = 汇编_读整数型 (#人物基址)
        二级偏移 = 汇编_读整数型 (一级偏移 + #地图偏移)
        .如果真 (二级偏移 = 0)
          返回 ()
        .如果真结束
        临时数据 = 汇编_读整数型 (#商店基址 - 8)
        临时数据 = 汇编_读整数型 (临时数据 + #时间基址)
        临时数据 = 汇编_读整数型 (临时数据 + #坐标结构偏移01)
        坐标结构 = 临时数据 + (方向ID + 方向ID × 4) × 8 + #坐标结构偏移02
        x = 汇编_读整数型 (坐标结构 + 0)
        y = 汇编_读整数型 (坐标结构 + 4)
        xF = 汇编_读整数型 (坐标结构 + 8)
        yF = 汇编_读整数型 (坐标结构 + 12)
        .如果真 (方向ID = 0)
          cx = x + xF + 20
          cy = y + yF ÷ 2
        .如果真结束
        .如果真 (方向ID = 1)
          cx = x - 20
          cy = y + yF ÷ 2
        .如果真结束
        .如果真 (方向ID = 2)
          cx = x + xF ÷ 2
          cy = y + yF + 20
        .如果真结束
        .如果真 (方向ID = 3)
          cx = x + xF ÷ 2
          cy = y - 20
        .如果真结束
        坐标CALL (一级偏移, cx, cy, 0)
        延时 (200)
        坐标CALL (一级偏移, x + xF ÷ 2, y, 0)
        .子程序 组包过图
        .参数 X索引, 整数型
        .参数 Y索引, 整数型
        缓冲Call (45)
        ?#29992;蹸all (X索引, 1)
        ?#29992;蹸all (Y索引, 1)
        ?#29992;蹸all (0, 4)
        ?#29992;蹸all (0, 4)
        ?#29992;蹸all (0, 1)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 4)
        ?#29992;蹸all (0, 4)
        ?#29992;蹸all (0, 4)
        ?#29992;蹸all (0, 4)
        ?#29992;蹸all (0, 4)
        ?#29992;蹸all (0, 4)
        ?#29992;蹸all (0, 4)
        ?#29992;蹸all (0, 4)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 4)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 4)
        ?#29992;蹸all (0, 4)
        ?#29992;蹸all (0, 4)
        ?#29992;蹸all (0, 2)
        ?#29992;蹸all (0, 1)
        发包Call ()
        .子程序 组包至上
        .局部变量 ?#32771;鋁, 整数型
        .局部变量 ?#32771;鋂, 整数型
        .如果真 (取是否开门 () = 真)
          ?#32771;鋁 = 汇编_取偏移地址 (汇编_减 (#商店基址, 8), { #时间基址, #A星偏移_3, 0 })
          ?#32771;鋂 = 汇编_取偏移地址 (汇编_减 (#商店基址, 8), { #时间基址, #A星偏移_4, 0 })
          组包过图 (?#32771;鋁, 汇编_减 (?#32771;鋂, 1))
        .如果真结束
        .子程序 组包至下
        .局部变量 ?#32771;鋁, 整数型
        .局部变量 ?#32771;鋂, 整数型
        .如果真 (取是否开门 () = 真)
          ?#32771;鋁 = 汇编_取偏移地址 (汇编_减 (#商店基址, 8), { #时间基址, #A星偏移_3, 0 })
          ?#32771;鋂 = 汇编_取偏移地址 (汇编_减 (#商店基址, 8), { #时间基址, #A星偏移_4, 0 })
          组包过图 (?#32771;鋁, 汇编_加 (?#32771;鋂, 1))
        .如果真结束
        .子程序 组包至左
        .局部变量 ?#32771;鋁, 整数型
        .局部变量 ?#32771;鋂, 整数型
        .如果真 (取是否开门 () = 真)
          ?#32771;鋁 = 汇编_取偏移地址 (汇编_减 (#商店基址, 8), { #时间基址, #A星偏移_3, 0 })
          ?#32771;鋂 = 汇编_取偏移地址 (汇编_减 (#商店基址, 8), { #时间基址, #A星偏移_4, 0 })
          组包过图 (汇编_减 (?#32771;鋁, 1), ?#32771;鋂)
        .如果真结束
        .子程序 组包至右
        .局部变量 ?#32771;鋁, 整数型
        .局部变量 ?#32771;鋂, 整数型
        .如果真 (取是否开门 () = 真)
          ?#32771;鋁 = 汇编_取偏移地址 (汇编_减 (#商店基址, 8), { #时间基址, #A星偏移_3, 0 })
          ?#32771;鋂 = 汇编_取偏移地址 (汇编_减 (#商店基址, 8), { #时间基址, #A星偏移_4, 0 })
          组包过图 (汇编_加 (?#32771;鋁, 1), ?#32771;鋂)
        .如果真结束
        .子程序 强制至上
        .如果真 (取是否开门 () = 真)
          强顺Call (2)
        .如果真结束
        .子程序 强制至下
        .如果真 (取是否开门 () = 真)
          强顺Call (3)
        .如果真结束
        .子程序 强制至左
        .如果真 (取是否开门 () = 真)
          强顺Call (0)
        .如果真结束
        .子程序 强制至右
        .如果真 (取是否开门 () = 真)
          强顺Call (1)
        .如果真结束
        .子程序 顺图至上
        .如果真 (取是否开门 () = 真)
          .判断开始 (剧情任务ID = 26 或 剧情任务ID = 15 或 剧情任务ID = 3191 或 全局_剧情ID = 15 或 全局_剧情ID = 88 或 全局_剧情ID = 190 或 全局_剧情ID = 35 或 全局_剧情ID = 3191 或 全局_剧情ID = 26) ' 剧情任务ID=15是天空之城
            强制至上 ()
          .默认
            顺图结构 (2)
          .判断结束
        .如果真结束
        .子程序 顺图至下
        .如果真 (取是否开门 () = 真)
          .判断开始 (剧情任务ID = 26 或 剧情任务ID = 15 或 剧情任务ID = 3191 或 全局_剧情ID = 15 或 全局_剧情ID = 88 或 全局_剧情ID = 190 或 全局_剧情ID = 35 或 全局_剧情ID = 3191 或 全局_剧情ID = 26)
            强制至下 ()
          .默认
            顺图结构 (3)
          .判断结束
        .如果真结束
        .子程序 顺图至左
        .如果真 (取是否开门 () = 真)
          .判断开始 (剧情任务ID = 26 或 剧情任务ID = 15 或 剧情任务ID = 3191 或 全局_剧情ID = 15 或 全局_剧情ID = 88 或 全局_剧情ID = 190 或 全局_剧情ID = 35 或 全局_剧情ID = 3191 或 全局_剧情ID = 26)
            强制至左 ()
          .默认
            顺图结构 (0)
          .判断结束
        .如果真结束
        .子程序 顺图至右
        .如果真 (取是否开门 () = 真)
          .判断开始 (剧情任务ID = 26 或 剧情任务ID = 15 或 剧情任务ID = 3191 或 全局_剧情ID = 15 或 全局_剧情ID = 88 或 全局_剧情ID = 190 或 全局_剧情ID = 35 或 全局_剧情ID = 3191 或 全局_剧情ID = 26) ' 剧情任务ID=3191是天帷巨兽
            强制至右 ()
          .默认
            顺图结构 (1)
          .判断结束
        .如果真结束
        .子程序 顺图调用
        .局部变量 过图方式, 整数型
        .局部变量 局_地图数据, 地图数据
        过图方式 = 文件读配置 (“过图方式”)
        局_地图数据 = 地图数据 ()
        顺图方向 = 顺图方向 (局_地图数据.地图走法 [1], 局_地图数据.地图走法 [2])
        .如果真 (过图方式 = 1)
          .如果真 (顺图方向 = 2)
            顺图至上 ()
          .如果真结束
          .如果真 (顺图方向 = 3)
            顺图至下 ()
          .如果真结束
          .如果真 (顺图方向 = 0)
            顺图至左 ()
          .如果真结束
          .如果真 (顺图方向 = 1)
            顺图至右 ()
          .如果真结束
        .如果真结束
        .如果真 (过图方式 = 2)
          .如果真 (顺图方向 = 2)
            强制至上 ()
          .如果真结束
          .如果真 (顺图方向 = 3)
            强制至下 ()
          .如果真结束
          .如果真 (顺图方向 = 0)
            强制至左 ()
          .如果真结束
          .如果真 (顺图方向 = 1)
            强制至右 ()
          .如果真结束
        .如果真结束

        总结

        以上就是这篇文章的全部内容了,希望本文的内容?#28304;?#23478;的学习或者工作具有一定的参考学习价值,谢谢大家对脚本之家的支持。如果你想了解更多相关内容请查看下面相关链接

        相关文章

        • 易语言通过时钟?#22270;?#27425;循环来实现定时任务的代码

          易语言通过时钟?#22270;?#27425;循环来实现定时任务的代码

          今天小编就为大家分享一篇关于易语言通过时钟?#22270;?#27425;循环来实现定时任务的代码,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
          2018-11-11
        • 易语言发音比较命令使用讲解

          易语言发音比较命令使用讲解

          今天小编就为大家分享一篇关于易语言发音比较命令使用讲解,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
          2018-11-11
        • 易语言取绝对?#24471;?#20196;使用讲解

          易语言取绝对?#24471;?#20196;使用讲解

          今天小编就为大家分享一篇关于易语言取绝对?#24471;?#20196;使用讲解,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
          2018-11-11
        • 易语言做软件更新的方法

          易语言做软件更新的方法

          在本篇文章中我们给大家分享了关于易语言做软件更新的方法和相关知识点,有需要的朋友们学习下。
          2019-01-01
        • 易语言更改编辑框中文字颜色的方法

          易语言更改编辑框中文字颜色的方法

          今天小编就为大家分享一篇关于易语言更改编辑框中文字颜色的方法,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
          2018-11-11
        • 详解易语言写ec模块的方法

          详解易语言写ec模块的方法

          在本篇内容里小编给大家分享了关于易语言写ec模块的方法内容,需要的朋友?#24378;?#20197;参?#23478;?#19979;。
          2018-11-11
        • 一步一步跟我学易语言之什?#35789;?#32534;程

          一步一步跟我学易语言之什?#35789;?#32534;程

          今天小编就为大家分享一篇关于一步一步跟我学易语言之什?#35789;?#32534;程,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
          2018-10-10
        • 易语言关闭显示器api详解

          易语言关闭显示器api详解

          小编在本篇内容中给大家整理了关于易语言关闭显示器api的详细实例代码,?#28304;?#26377;需要的朋友?#24378;?#20197;学习一下。
          2018-11-11
        • 易语言取时间间隔命令使用讲解

          易语言取时间间隔命令使用讲解

          今天小编就为大家分享一篇关于易语言取时间间隔命令使用讲解,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
          2018-11-11
        • 易语言关于程序进程和线程的基础知识

          易语言关于程序进程和线程的基础知识

          今天小编就为大家分享一篇关于易语言关于程序进程和线程的基础知识,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
          2018-12-12

        最新评论

        2018白小姐一肖中特马
        <sup id="sjju3"><noscript id="sjju3"></noscript></sup>
        <big id="sjju3"></big>

      2. <blockquote id="sjju3"></blockquote>
        <blockquote id="sjju3"></blockquote>

          <td id="sjju3"></td>

          <big id="sjju3"></big>
            <code id="sjju3"><strong id="sjju3"><dl id="sjju3"></dl></strong></code>
          1. <sup id="sjju3"><noscript id="sjju3"></noscript></sup>
            <big id="sjju3"></big>

          2. <blockquote id="sjju3"></blockquote>
            <blockquote id="sjju3"></blockquote>

              <td id="sjju3"></td>

              <big id="sjju3"></big>
                <code id="sjju3"><strong id="sjju3"><dl id="sjju3"></dl></strong></code>